I like where this is going and I have some suggestions, which you don't have to agree with
Rename RollbarCreateItem to Rollbar_Send
I understand what you are trying to convey, by having the API item as part of the name, but "CreateItem" in this case is also sending data to Rollbar
Create help functions e.g.
Rollbar_SendDebug
Rollbar_SendInfo
....
Writing to the console should be opt-in and not on by default, either by using a flag or by asking for a logging function
RollbarCreateItem is quite big, and can be broken down into smaller functions
Validation of the API token would be good
Keep it up!